diff configure.in @ 3091:0704b595c873 HEAD

Give -std=gnu99 option to gcc.
author Timo Sirainen <tss@iki.fi>
date Thu, 13 Jan 2005 15:37:09 +0200
parents 5e2e4cdbfe2e
children 3ba362513202
line wrap: on
line diff
--- a/configure.in	Wed Jan 12 23:26:36 2005 +0200
+++ b/configure.in	Thu Jan 13 15:37:09 2005 +0200
@@ -1,4 +1,4 @@
-AC_INIT(dovecot, 1.0-test59, [dovecot@dovecot.org])
+AC_INIT(dovecot, 1.0-test60, [dovecot@dovecot.org])
 AC_CONFIG_SRCDIR([src])
 
 AC_CONFIG_HEADERS([config.h])
@@ -233,6 +233,10 @@
 	# -Wstrict-prototypes -Wredundant-decls # may give warnings in some systems
 	# -Wmissing-format-attribute -Wmissing-noreturn -Wwrite-strings # a couple of warnings
 	CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast"
+
+	# say specifically that we want C99 features.
+	# we can make use of GNU features as well, so don't use -std=c99.
+	CFLAGS="$CFLAGS -std=gnu99"
 fi
 
 dnl **