diff configure.in @ 1626:08b73ec005f8 HEAD

Get the size_t type properly in OSX
author Timo Sirainen <tss@iki.fi>
date Tue, 15 Jul 2003 23:24:21 +0300
parents 4f38b6de621a
children e9e533b323fb
line wrap: on
line diff
--- a/configure.in	Tue Jul 15 22:19:30 2003 +0300
+++ b/configure.in	Tue Jul 15 23:24:21 2003 +0300
@@ -428,13 +428,16 @@
   AC_MSG_RESULT(no)
 ])
 
-AC_TYPEOF(ssize_t)
-case "$typeof_ssize_t" in
-  long)
+dnl Note: we check size_t rather than ssize_t here, because on OSX 10.2
+dnl ssize_t = int and size_t = unsigned long. We're mostly concerned about
+dnl printf format here, so check the size_t one.
+AC_TYPEOF(size_t, unsigned-int unsigned-long unsigned-long-long)
+case "$typeof_size_t" in
+  "unsigned long")
     ssizet_max=LONG_MAX
     sizet_fmt="lu"
     ;;
-  "long long")
+  "unsigned long long")
     ssizet_max=LLONG_MAX
     sizet_fmt="llu"
     ;;
@@ -443,7 +446,7 @@
     ssizet_max=INT_MAX
     sizet_fmt="u"
 
-    if test "$typeof_ssize_t" = ""; then
+    if test "$typeof_size_t" = ""; then
       AC_DEFINE(size_t, unsigned int, Define to 'unsigned int' if you don't have it)
       AC_DEFINE(ssize_t, int, Define to 'int' if you don't have it)
     fi