diff configure.in @ 179:0ffecd4e7e1a HEAD

added dec2str() function and largest_t type, removed itoa() and ltoa() macros and did some other cleanups.
author Timo Sirainen <tss@iki.fi>
date Sun, 08 Sep 2002 14:36:03 +0300
parents 73bf05a1d862
children 4a7ab9e94f25
line wrap: on
line diff
--- a/configure.in	Sun Sep 08 13:25:02 2002 +0300
+++ b/configure.in	Sun Sep 08 14:36:03 2002 +0300
@@ -153,6 +153,12 @@
   AC_ERROR([Couldn't find integer type for off_t])
 fi
 
+if test x$ac_cv_sizeof_long_long != x0; then
+  AC_DEFINE(LARGEST_T_LONG_LONG)
+else
+  AC_DEFINE(LARGEST_T_LONG)
+fi
+
 dnl * memory alignment, needed with non-x86 systems and should speed up
 dnl * x86 systems too. Use 8 with everyone to make sure 64bit lookups
 dnl * work. Currently it should also be safe to set to 4 if off_t == 32bit.