diff configure.ac @ 16346:139ab37f69df

configure: Fixed checking for struct sockpeercred with OpenBSD <5.3
author Timo Sirainen <tss@iki.fi>
date Tue, 14 May 2013 14:14:16 +0300
parents da8120a3a98d
children 7aa929edd551
line wrap: on
line diff
--- a/configure.ac	Tue May 14 14:02:36 2013 +0300
+++ b/configure.ac	Tue May 14 14:14:16 2013 +0300
@@ -433,7 +433,10 @@
 	       walkcontext dirfd clearenv malloc_usable_size glob fallocate \
 	       posix_fadvise getpeereid getpeerucred)
 
-AC_CHECK_TYPES([struct sockpeercred],,,[#include <sys/socket.h>])
+AC_CHECK_TYPES([struct sockpeercred],,,[
+#include <sys/types.h>
+#include <sys/socket.h>
+])
 
 AC_SEARCH_LIBS(clock_gettime, rt, [
   AC_DEFINE(HAVE_CLOCK_GETTIME,, Define if you have the clock_gettime function)