diff Makefile.am @ 18246:16c21c12e21f

dovecot-config: Added DOVECOT_INSTALLED parameter. Also added dovecot_installed_moduledir to dovecot.m4 These can be used by external plugins to access some headers and libraries that don't already have existing DOVECOT_* parameters in dovecot-config.
author Timo Sirainen <tss@iki.fi>
date Fri, 13 Feb 2015 14:35:54 +0200
parents 3675d156b309
children 86d382b0c4d8
line wrap: on
line diff
--- a/Makefile.am	Thu Feb 12 14:38:18 2015 +0200
+++ b/Makefile.am	Fri Feb 13 14:35:54 2015 +0200
@@ -37,7 +37,7 @@
 dovecot-config: dovecot-config.in Makefile
 	old=`pwd` && cd $(top_builddir) && abs_builddir=`pwd` && cd $$old && \
 	cd $(top_srcdir) && abs_srcdir=`pwd` && cd $$old && \
-	cat dovecot-config.in | sed \
+	(echo "DOVECOT_INSTALLED=no"; cat dovecot-config.in | sed \
 	-e "s|\$$(top_builddir)|$$abs_builddir|g" \
 	-e "s|\$$(incdir)|$$abs_srcdir|g" \
 	-e "s|\$$(LIBICONV)|$(LIBICONV)|g" \
@@ -47,7 +47,7 @@
 	-e "s|^\(dovecot_pkglibexecdir\)=|\1=$(libexecdir)/dovecot|" \
 	-e "s|^\(dovecot_docdir\)=|\1=$(docdir)|" \
 	-e "s|^\(dovecot_moduledir\)=|\1=$(moduledir)|" \
-	> dovecot-config
+	) > dovecot-config
 
 if HAVE_SYSTEMD
 %.service: %.service.in
@@ -64,6 +64,7 @@
 	$(mkdir_p) $(DESTDIR)$(pkglibdir); \
 	grep -v '^LIBDOVECOT_.*_INCLUDE' dovecot-config | \
 	grep -v '^LIBDOVECOT.*_DEPS' | sed \
+	-e "s|^\(DOVECOT_INSTALLED\)=.*$$|\1=yes|" \
 	-e "s|^\(LIBDOVECOT\)=.*$$|\1='-L$(pkglibdir) -ldovecot'|" \
 	-e "s|^\(LIBDOVECOT_LOGIN\)=.*$$|\1='-ldovecot-login $(SSL_LIBS)'|" \
 	-e "s|^\(LIBDOVECOT_SQL\)=.*$$|\1=-ldovecot-sql|" \