diff configure.ac @ 18337:16ff063e3588

dict: cdb support should be available only to dict process. Because otherwise we need to link libcdb into pretty much all Dovecot binaries, which is part of what having the dict proxy tries to avoid. We could implement the direct linking optionally as well, but that would need to be done in a bit more generic way rather than just hardcoding it only to cdb support.
author Timo Sirainen <tss@iki.fi>
date Thu, 12 Mar 2015 15:42:31 +0200
parents a3c27cec4112
children 0f8f0d8ee607
line wrap: on
line diff
--- a/configure.ac	Thu Mar 12 15:33:13 2015 +0200
+++ b/configure.ac	Thu Mar 12 15:42:31 2015 +0200
@@ -2129,6 +2129,7 @@
   AC_CHECK_LIB(cdb, cdb_init, [
     AC_CHECK_HEADER(cdb.h, [
       DICT_LIBS="$DICT_LIBS -lcdb"
+      dict_drivers="$dict_drivers cdb"
       AC_DEFINE(BUILD_CDB,, Build with CDB support)
     ], [
       if test $want_cdb = yes; then