diff configure.in @ 1150:18a2074a4d3d HEAD

Support for dynamic authentication modules.
author Timo Sirainen <tss@iki.fi>
date Tue, 11 Feb 2003 20:01:38 +0200
parents 2ea48622afbc
children f7c273202dc3
line wrap: on
line diff
--- a/configure.in	Tue Feb 11 19:42:31 2003 +0200
+++ b/configure.in	Tue Feb 11 20:01:38 2003 +0200
@@ -814,6 +814,17 @@
 	])
 fi
 
+dnl * dynamic modules?
+AC_CHECK_LIB(dl, dlopen, [
+  PASSDB_LIBS="$PASSDB_LIBS -ldl"
+  AC_DEFINE(AUTH_MODULES,, Define if you want to build with dynamic auth modules)
+  auth_modules=yes
+  userdb="$userdb (modules)"
+  passdb="$passdb (modules)"
+])
+
+AM_CONDITIONAL(AUTH_MODULES, test "$auth_modules" = "yes")
+
 AC_SUBST(PASSDB_LIBS)
 
 dnl **
@@ -917,8 +928,8 @@
 echo
 echo "Install prefix ...................... : $prefix"
 echo "File offsets ........................ : ${offt_bits}bit"
-echo "Building with user database modules . :$userdb"
-echo "Building with password lookup modules :$passdb"
 echo "Building with SSL support ........... : $have_ssl"
 echo "Building with IPv6 support .......... : $want_ipv6"
 echo "Building with pop3 server ........... : $want_pop3d"
+echo "Building with user database modules . :$userdb"
+echo "Building with password lookup modules :$passdb"