diff configure.in @ 4407:2e4857a2b858 HEAD

Added --with-statedir configure option which defaults to localstatedir/lib/dovecot. ssl-parameters.dat is permanently stored in that directory and copied to login_dirs from there.
author Timo Sirainen <tss@iki.fi>
date Sat, 17 Jun 2006 19:26:54 +0300
parents 670dd15edbf3
children a2420b745cd5
line wrap: on
line diff
--- a/configure.in	Sat Jun 17 19:24:55 2006 +0300
+++ b/configure.in	Sat Jun 17 19:26:54 2006 +0300
@@ -234,6 +234,13 @@
 )
 AC_SUBST(rundir)
 
+AC_ARG_WITH(statedir,
+[  --with-statedir=DIR     Permanent data directory (LOCALSTATEDIR/lib/dovecot)],
+	statedir="$withval",
+	statedir=$localstatedir/lib/$PACKAGE_NAME
+)
+AC_SUBST(statedir)
+
 AC_ARG_WITH(gc,
 [  --with-gc               Use Boehm garbage collector (currently broken)],
 	if test x$withval = xyes; then