diff configure.in @ 14989:3765e8948f1c

configure: Removed OpenBSD /dev/arandom checking. Patch by Brad Smith "The use of arandom was never a requirement for Dovecot and I had submitted the use of arandom due to ports policy to do so anyway."
author Timo Sirainen <tss@iki.fi>
date Wed, 22 Aug 2012 17:42:06 +0300
parents 670f467ff5c5
children 1f95d4fe29c7 f5bb9f6b304d
line wrap: on
line diff
--- a/configure.in	Wed Aug 22 15:17:53 2012 +0300
+++ b/configure.in	Wed Aug 22 17:42:06 2012 +0300
@@ -951,21 +951,13 @@
 AC_DEFINE_UNQUOTED(MEM_ALIGN_SIZE, $mem_align, Required memory alignment)
 
 dnl * find random source
-AC_MSG_CHECKING([for OpenBSD /dev/arandom])
-if test -c /dev/arandom; then
+AC_MSG_CHECKING([for /dev/urandom])
+if test -c /dev/urandom || test -s /dev/urandom; then
   AC_MSG_RESULT(yes)
-  AC_DEFINE(DEV_URANDOM_PATH, "/dev/arandom", Path to /dev/urandom)
+  AC_DEFINE(DEV_URANDOM_PATH, "/dev/urandom", Path to /dev/urandom)
   have_random_source=yes
 else
   AC_MSG_RESULT(no)
-  AC_MSG_CHECKING([for /dev/urandom])
-  if test -c /dev/urandom || test -s /dev/urandom; then
-    AC_MSG_RESULT(yes)
-    AC_DEFINE(DEV_URANDOM_PATH, "/dev/urandom", Path to /dev/urandom)
-    have_random_source=yes
-  else
-    AC_MSG_RESULT(no)
-  fi
 fi
 
 if test "$have_random_source" != "yes"; then