diff configure.in @ 4621:446646de0c4a HEAD

--with-lucene now enables lucene full text search indexing. Note that using it breaks IMAP RFC. It also seems to have problems finding texts that have special characters in them, such as email addresses. You can anyway enable it by loading fts and fts_lucene plugins and setting fts=lucene in plugin section.
author Timo Sirainen <tss@iki.fi>
date Mon, 18 Sep 2006 02:15:53 +0300
parents 48a16f1254b5
children 689a02ca02d3
line wrap: on
line diff
--- a/configure.in	Mon Sep 18 02:08:35 2006 +0300
+++ b/configure.in	Mon Sep 18 02:15:53 2006 +0300
@@ -218,6 +218,16 @@
 	fi,
 	want_sqlite=no)
 
+AC_ARG_WITH(lucene,
+[  --with-lucene           Build with CLucene full text search support],
+	if test x$withval = xno; then
+		want_lucene=no
+	else
+		want_lucene=yes
+	fi,
+	want_lucene=no)
+AM_CONDITIONAL(BUILD_LUCENE, test "$want_lucene" = "yes")
+
 AC_ARG_WITH(ssl,
 [  --with-ssl=[gnutls|openssl] Build with GNUTLS or OpenSSL (default)],
 	if test x$withval = xno; then
@@ -1801,6 +1811,7 @@
 src/plugins/convert/Makefile
 src/plugins/expire/Makefile
 src/plugins/fts/Makefile
+src/plugins/fts-lucene/Makefile
 src/plugins/quota/Makefile
 src/plugins/imap-quota/Makefile
 src/plugins/trash/Makefile