diff configure.in @ 11871:45b835e6f59c

configure: Make sure mysql libs/cflags aren't used if they don't work.
author Timo Sirainen <tss@iki.fi>
date Tue, 20 Jul 2010 20:23:20 +0100
parents 8cf47a359213
children a15b694f1d64
line wrap: on
line diff
--- a/configure.in	Tue Jul 20 17:21:29 2010 +0100
+++ b/configure.in	Tue Jul 20 20:23:20 2010 +0100
@@ -2142,6 +2142,7 @@
   LIBS=$old_LIBS
 fi
 
+have_mysql=no
 if test $want_mysql != no; then
   AC_CHECK_PROG(MYSQL_CONFIG, mysql_config, YES, NO)
   if test $MYSQL_CONFIG = NO; then
@@ -2197,6 +2198,7 @@
 				])
 			])
 			
+			have_mysql=yes
 			AC_DEFINE(HAVE_MYSQL,, Build with MySQL support)
 			found_sql_drivers="$found_sql_drivers mysql"
 		], [
@@ -2211,6 +2213,10 @@
     fi
   ])
 
+  if test $have_mysql != yes; then
+    MYSQL_LIBS=
+    MYSQL_CFLAGS=
+  fi
   LIBS=$old_LIBS
 fi