diff configure.ac @ 15935:4baf0183f13d

Reverted the recent hash.h changes. Instead use -Wno-duplicate-decl-specifier with clang. The modified version required hash table users to know the structs' contents, which isn't otherwise necessary.
author Timo Sirainen <tss@iki.fi>
date Mon, 25 Feb 2013 16:12:49 +0200
parents 217fb4ca9b5a
children 508d46f85815
line wrap: on
line diff
--- a/configure.ac	Mon Feb 25 15:55:06 2013 +0200
+++ b/configure.ac	Mon Feb 25 16:12:49 2013 +0200
@@ -318,7 +318,16 @@
 	# -Wmissing-format-attribute -Wmissing-noreturn -Wwrite-strings # a couple of warnings
 	CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast"
 
-	if test "$have_clang" != "yes"; then
+	if test "$have_clang" = "yes"; then
+	  AC_TRY_COMPILE([
+	  #if __clang_major__ > 3 || (__clang_major__ == 3 && __clang_minor__ >= 3)
+	  #  error new clang
+	  #endif
+	  ],,,[
+	    # clang 3.3+ unfortunately this gives warnings with hash.h
+	    CFLAGS="$CFLAGS -Wno-duplicate-decl-specifier"
+	  ])
+	else
 	  # This is simply to avoid warning when building strftime() wrappers..
 	  CFLAGS="$CFLAGS -fno-builtin-strftime"
 	fi