diff configure.in @ 10980:5b0a88cb9a12 HEAD

configure: Fixed libwrap checking in some systems.
author Timo Sirainen <tss@iki.fi>
date Thu, 25 Mar 2010 17:41:16 +0200
parents 38e98c234af5
children c78fe7920deb
line wrap: on
line diff
--- a/configure.in	Thu Mar 25 17:33:40 2010 +0200
+++ b/configure.in	Thu Mar 25 17:41:16 2010 +0200
@@ -344,16 +344,30 @@
 if test $want_libwrap != no; then
   AC_CHECK_HEADER(tcpd.h, [
     old_LIBS=$LIBS
-    AC_CHECK_LIB(wrap, request_init, [
+
+    AC_CACHE_CHECK([whether we have libwrap],i_cv_have_libwrap,[
+      AC_TRY_COMPILE([
+	#include <tcpd.h>
+	int allow_severity = 0;
+	int deny_severity = 0;
+      ], [
+	request_init((void *)0);
+      ], [
+	i_cv_have_libwrap=yes
+      ], [
+	i_cv_have_libwrap=no
+      ])
+    ])
+    if test $i_cv_have_libwrap = yes; then
       AC_DEFINE(HAVE_LIBWRAP,, Define if you have libwrap)
       LIBWRAP_LIBS=-lwrap
       AC_SUBST(LIBWRAP_LIBS)
       have_libwrap=yes
-    ], [
+    else
       if test "$want_libwrap" = "yes"; then
 	AC_ERROR([Can't build with libwrap support: libwrap not found])
       fi
-    ])
+    fi
     LIBS=$old_LIBS
   ], [
     if test "$want_libwrap" = "yes"; then