diff configure.ac @ 15926:5be9659a2738

configure: Removed accidentally enabled clang -fsanitize options for now.
author Timo Sirainen <tss@iki.fi>
date Mon, 25 Feb 2013 09:07:13 +0200
parents d3cf06639864
children 61508a42a44b
line wrap: on
line diff
--- a/configure.ac	Sun Feb 24 19:48:55 2013 +0200
+++ b/configure.ac	Mon Feb 25 09:07:13 2013 +0200
@@ -290,7 +290,6 @@
 AC_PROG_CXX # lucene plugin needs this
 AC_HEADER_STDC
 AC_C_INLINE
-AC_C_TYPEOF
 AC_PROG_LIBTOOL
 AM_ICONV
 
@@ -346,7 +345,8 @@
 if test "$have_clang" = "yes"; then
   # clang specific options
   if test "$want_devel_checks" = "yes"; then
-    CFLAGS="$CFLAGS -fsanitize=address,integer,undefined -ftrapv"
+    # FIXME: enable once md[45], sha[12] can be compiled without
+    #CFLAGS="$CFLAGS -fsanitize=integer,undefined -ftrapv"
   fi
 fi