diff configure.ac @ 18131:6078354e6238

configure: Don't break when using --without-shared-libs and CC with '/' chars.
author Timo Sirainen <tss@iki.fi>
date Fri, 26 Dec 2014 17:28:30 +0200
parents e8b793f2c409
children d938a49c2045
line wrap: on
line diff
--- a/configure.ac	Wed Dec 17 14:43:30 2014 +0100
+++ b/configure.ac	Fri Dec 26 17:28:30 2014 +0200
@@ -2805,7 +2805,7 @@
   # libtool can't handle using whole-archive flags, so we need to do this
   # with a CC wrapper.. shouldn't be much of a problem, since most people
   # are building with shared libs.
-  sed "s/@CC@/$CC/" < $srcdir/cc-wrapper.sh.in > cc-wrapper.sh
+  sed "s:@CC@:$CC:" < $srcdir/cc-wrapper.sh.in > cc-wrapper.sh
   chmod +x cc-wrapper.sh
   CC=`pwd`/cc-wrapper.sh
 fi