diff configure.ac @ 15927:61508a42a44b

configure: Fix previous commit & implement AC_C_TYPEOF ourself. RHEL5's autoconf was old enough to not have AC_C_TYPEOF.
author Timo Sirainen <tss@iki.fi>
date Mon, 25 Feb 2013 09:12:06 +0200
parents 5be9659a2738
children 217fb4ca9b5a
line wrap: on
line diff
--- a/configure.ac	Mon Feb 25 09:07:13 2013 +0200
+++ b/configure.ac	Mon Feb 25 09:12:06 2013 +0200
@@ -347,6 +347,7 @@
   if test "$want_devel_checks" = "yes"; then
     # FIXME: enable once md[45], sha[12] can be compiled without
     #CFLAGS="$CFLAGS -fsanitize=integer,undefined -ftrapv"
+    :
   fi
 fi
 
@@ -426,6 +427,21 @@
   AC_DEFINE(HAVE_CLOCK_GETTIME,, Define if you have the clock_gettime function)
 ])
 
+AC_CACHE_CHECK([for typeof],i_cv_have_typeof,[
+  AC_TRY_COMPILE([
+  ], [
+    int foo;
+    typeof(foo) bar;
+  ], [
+    i_cv_have_typeof=yes
+  ], [
+    i_cv_have_typeof=no
+  ])
+])
+if test $i_cv_have_typeof = yes; then
+  AC_DEFINE(HAVE_TYPEOF,, Define if you have typeof())
+fi
+
 dnl strtoimax and strtoumax are macros in HP-UX, so inttypes.h must be included
 dnl Link instead of just compiling since there's something wrong with Tru64
 AC_CACHE_CHECK([for strtoimax],i_cv_have_strtoimax,[