diff configure.ac @ 17053:7a7898ffe87f

mysql: Added ssl_verify_server_cert=no|yes parameter. To make sure we don't break existing installations, default to "no". For v2.3 it should default to "yes". Patch by Gareth Palmer
author Timo Sirainen <tss@iki.fi>
date Mon, 09 Dec 2013 00:02:58 +0200
parents 2852a7c55fc7
children 614bd6600011
line wrap: on
line diff
--- a/configure.ac	Sun Dec 08 23:41:33 2013 +0200
+++ b/configure.ac	Mon Dec 09 00:02:58 2013 +0200
@@ -2287,6 +2287,15 @@
 				  mysql_set_ssl(0, 0, 0, 0, 0, 0);
 				], [
 					AC_DEFINE(HAVE_MYSQL_SSL_CIPHER,, Define if your MySQL library supports setting cipher)
+
+					AC_TRY_COMPILE([
+					  $ssl_define
+					  #include <mysql.h>
+					], [
+					  int i = MYSQL_OPT_SSL_VERIFY_SERVER_CERT;
+					], [
+						AC_DEFINE(HAVE_MYSQL_SSL_VERIFY_SERVER_CERT,, Define if your MySQL library supports verifying the name in the SSL certificate)
+					])
 				])
 			])