diff configure.in @ 5035:80f0ee36e905 HEAD

Allow --with-vpopmail=path specify the vpopmail_home path.
author Timo Sirainen <tss@iki.fi>
date Thu, 18 Jan 2007 21:51:18 +0200
parents 1b28e0434d85
children 050549cfaa25
line wrap: on
line diff
--- a/configure.in	Thu Jan 18 20:45:33 2007 +0200
+++ b/configure.in	Thu Jan 18 21:51:18 2007 +0200
@@ -160,8 +160,15 @@
 		want_vpopmail=no
 	else
 		want_vpopmail=yes
-	fi,
-	want_vpopmail=yes)
+		if test x$withval = xyes; then
+			vpopmail_home="`echo ~vpopmail`"
+		else
+			vpopmail_home="$withval"
+		fi
+	fi, [
+		want_vpopmail=yes
+		vpopmail_home="`echo ~vpopmail`"
+	])
 
 AC_ARG_WITH(static-userdb,
 [  --with-static-userdb    Build with static userdb support (default)],
@@ -1687,7 +1694,6 @@
 fi
 
 if test $want_vpopmail = yes; then
-	vpopmail_home="`echo ~vpopmail`"
 	vpop_libdeps="$vpopmail_home/etc/lib_deps"
 
 	AC_MSG_CHECKING([for vpopmail configuration at $vpop_libdeps])