diff configure.in @ 8068:9569038e0816 HEAD

gssapi: Make auth_krb5_keytab work by calling _register_acceptor_identity() instead of relying on KRB5_KTNAME environment to be picked up.
author Timo Sirainen <tss@iki.fi>
date Mon, 04 Aug 2008 17:33:09 -0400
parents 1894a0b4957d
children bbfbc84f795c
line wrap: on
line diff
--- a/configure.in	Mon Aug 04 17:04:40 2008 -0400
+++ b/configure.in	Mon Aug 04 17:33:09 2008 -0400
@@ -1782,6 +1782,13 @@
 					KRB5_LIBS="$KRB5_LIBS -lgss"
 				],, $KRB5_LIBS)
 
+				# MIT has a #define for Heimdal acceptor_identity, but it's way too
+				# difficult to test for it..
+				old_LIBS=$LIBS
+				LIBS="$LIBS $KRB5_LIBS"
+				AC_CHECK_FUNCS(gsskrb5_register_acceptor_identity krb5_gss_register_acceptor_identity)
+				LIBS=$old_LIBS
+
 				if test x$want_gssapi_plugin != xyes; then
 				  AUTH_LIBS="$AUTH_LIBS $KRB5_LIBS"
 				  AUTH_CFLAGS="$AUTH_CFLAGS $KRB5_CFLAGS"