diff configure.in @ 9410:ab69375b8422 HEAD

configure: If all passdb/userdb/sql drivers are compiled, don't print an empty line for them.
author Timo Sirainen <tss@iki.fi>
date Sun, 31 May 2009 15:22:32 -0400
parents ed142749ce67
children b20513ab8f5a
line wrap: on
line diff
--- a/configure.in	Sun May 31 15:19:37 2009 -0400
+++ b/configure.in	Sun May 31 15:22:32 2009 -0400
@@ -2509,11 +2509,17 @@
 echo "SSL ............ : $have_ssl"
 echo "GSSAPI ......... : $have_gssapi"
 echo "passdbs ........ :$passdb"
-echo "                 :$not_passdb"
+if test "$not_passdb" != ""; then
+  echo "                 :$not_passdb"
+fi
 echo "userdbs ........ :$userdb"
-echo "                 :$not_userdb"
+if test "$not_userdb" != ""; then
+  echo "                 :$not_userdb"
+fi
 echo "SQL drivers .... :$sql_drivers"
-echo "                 :$not_sql_drivers"
+if test "$not_sql_drivers" != ""; then
+  echo "                 :$not_sql_drivers"
+fi
 
 echo
 echo "NOTE: This is the UNSTABLE development branch of Dovecot v2.0."