diff configure.ac @ 15498:af5265e74b9e

configure: Use pkg-config with clucene if available.
author Timo Sirainen <tss@iki.fi>
date Fri, 04 Jan 2013 05:49:33 +0200
parents ac63858cbe5f
children 13e74bd5ac8c
line wrap: on
line diff
--- a/configure.ac	Fri Jan 04 01:43:59 2013 +0200
+++ b/configure.ac	Fri Jan 04 05:49:33 2013 +0200
@@ -2660,6 +2660,11 @@
 
 have_lucene=no
 if test "$want_lucene" = "yes"; then
+  PKG_CHECK_MODULES(CLUCENE, libclucene-core,, [
+    # no pkg-config file for clucene. fallback to defaults.
+    # FIXME: we should verify here that this actually works..
+    CLUCENE_LIBS="-lclucene-shared -lclucene-core"
+  ])
   if test $want_stemmer != no; then
     AC_CHECK_LIB(stemmer, sb_stemmer_new, [
       have_lucene_stemmer=yes