diff configure.ac @ 18439:b179bbd226e5

configure: s/normalizer/libicu/ since we it could be used for something else as well.
author Timo Sirainen <tss@iki.fi>
date Tue, 21 Apr 2015 19:31:14 +0300
parents 50ef619ce58a
children e4ad83ed88c9
line wrap: on
line diff
--- a/configure.ac	Tue Apr 21 17:01:39 2015 +0300
+++ b/configure.ac	Tue Apr 21 19:31:14 2015 +0300
@@ -169,10 +169,10 @@
   TEST_WITH(textcat, $withval),
   want_textcat=auto)
 
-AC_ARG_WITH(normalizer,
-AS_HELP_STRING([--with-normalizer], [Build lib-fts with ICU normalization support (auto)]),
-  want_fts_normalizer=$withval,
-  want_fts_normalizer=auto)
+AC_ARG_WITH(icu,
+AS_HELP_STRING([--with-icu], [Build with libicu support (for FTS normalization) (auto)]),
+  want_icu=$withval,
+  want_icu=auto)
 
 AC_ARG_WITH(solr,
 AS_HELP_STRING([--with-solr], [Build with Solr full text search support]),
@@ -2799,16 +2799,16 @@
 AM_CONDITIONAL(BUILD_FTS_TEXTCAT, test "$have_fts_textcat" = "yes")
 AM_CONDITIONAL(BUILD_FTS_EXTTEXTCAT, test "$have_fts_exttextcat" = "yes")
 
-if test "$want_fts_normalizer" != "no"; then
+if test "$want_icu" != "no"; then
   if test "$PKG_CONFIG" != "" && $PKG_CONFIG --exists icu-i18n 2>/dev/null; then
-    PKG_CHECK_MODULES(FTS_NORMALIZER, icu-i18n)
-    have_fts_normalizer=yes
-    AC_DEFINE(HAVE_FTS_NORMALIZER,, Define if you want ICU normalization support for FTS)
-  elif test "$want_fts_normalizer" = "yes"; then
-    AC_ERROR([Can't build with normalizer support: libicu-i18n not found])
+    PKG_CHECK_MODULES(LIBICU, icu-i18n)
+    have_icu=yes
+    AC_DEFINE(HAVE_LIBICU,, Define if you want ICU normalization support for FTS)
+  elif test "$want_icu" = "yes"; then
+    AC_ERROR([Can't build with libicu support: libicu-i18n not found])
   fi
 fi
-AM_CONDITIONAL(BUILD_FTS_NORMALIZER, test "$have_fts_normalizer" = "yes")
+AM_CONDITIONAL(BUILD_LIBICU, test "$have_icu" = "yes")
 
 if test $have_lucene = no; then
   not_fts="$not_fts lucene"