diff configure.ac @ 15755:b9b8286fd9fd

fts-solr: Use built-in lib-http instead of libcurl. Removed libcurl dependency.
author Stephan Bosch <stephan@rename-it.nl>
date Mon, 11 Feb 2013 01:43:25 +0200
parents 2c249941f9c2
children e63d1cf19ec7
line wrap: on
line diff
--- a/configure.ac	Mon Feb 11 01:22:51 2013 +0200
+++ b/configure.ac	Mon Feb 11 01:43:25 2013 +0200
@@ -2642,33 +2642,21 @@
 
 have_solr=no
 if test "$want_solr" != "no"; then
-  AC_CHECK_PROG(CURLCONFIG, curl-config, curl-config, NO)
-  if test $CURLCONFIG != NO; then
-    CURL_CFLAGS=`$CURLCONFIG --cflags`
-    CURL_LIBS=`$CURLCONFIG --libs`
-    
-    dnl libcurl found, also need libexpat
-    AC_CHECK_LIB(expat, XML_Parse, [
-      AC_CHECK_HEADER(expat.h, [
-        AC_SUBST(CURL_CFLAGS)
-        AC_SUBST(CURL_LIBS)
-	have_solr=yes
-        fts="$fts solr"
-      ], [
-	if test $want_solr = yes; then
-	  AC_ERROR([Can't build with Solr support: expat.h not found])
-	fi
-      ])
+  dnl need libexpat
+  AC_CHECK_LIB(expat, XML_Parse, [
+    AC_CHECK_HEADER(expat.h, [
+      have_solr=yes
+      fts="$fts solr"
     ], [
       if test $want_solr = yes; then
-	AC_ERROR([Can't build with Solr support: libexpat not found])
+        AC_ERROR([Can't build with Solr support: expat.h not found])
       fi
     ])
-  else
+  ], [
     if test $want_solr = yes; then
-      AC_ERROR([Can't build with Solr support: curl-config not found])
+      AC_ERROR([Can't build with Solr support: libexpat not found])
     fi
-  fi
+  ])
 fi
 AM_CONDITIONAL(BUILD_SOLR, test "$have_solr" = "yes")