diff configure.in @ 9973:ba12a404d3b3 HEAD

Compiling fix for OpenSSL 0.9.7 and older.
author Timo Sirainen <tss@iki.fi>
date Tue, 06 Oct 2009 10:53:34 -0400
parents a22c9e8a01ae
children 0bb321c347ae
line wrap: on
line diff
--- a/configure.in	Mon Oct 05 19:45:10 2009 -0400
+++ b/configure.in	Tue Oct 06 10:53:34 2009 -0400
@@ -1570,6 +1570,10 @@
   if test "$have_openssl" = "yes"; then
     AC_DEFINE(HAVE_OPENSSL,, Build with OpenSSL support)
     have_ssl="yes (OpenSSL)"
+
+    AC_CHECK_LIB(ssl, SSL_get_current_compression, [
+      AC_DEFINE(HAVE_SSL_COMPRESSION,, Build with OpenSSL compression)
+    ],, $SSL_LIBS)
   fi
 fi