diff configure.in @ 3782:c67f77647a6e HEAD

Added kqueue notification support. Patch by Vaclav Haisman
author Timo Sirainen <tss@iki.fi>
date Fri, 30 Dec 2005 22:56:39 +0200
parents 0128534525d8
children 1a1f8789415a
line wrap: on
line diff
--- a/configure.in	Fri Dec 30 22:56:05 2005 +0200
+++ b/configure.in	Fri Dec 30 22:56:39 2005 +0200
@@ -339,12 +339,17 @@
 fi
 
 if test "$ioloop" = "kqueue"; then
-  AC_CHECK_FUNC(kqueue, [
-    AC_DEFINE(IOLOOP_KQUEUE,, [Implement I/O loop with FreeBSD kqueue()])
+  if test "$ac_cv_func_kqueue" != yes ; then
+    AC_MSG_WARN([kqueue ioloop requested but kqueue() is not available])
+    ioloop=""
+  elif test "$ac_cv_func_kevent" != yes ; then
+    AC_MSG_WARN([kqueue ioloop requested but kevent() is not available])
+    ioloop=""
+  else
+    AC_DEFINE(IOLOOP_KQUEUE,, [Implement I/O loop with BSD kqueue()])
+    ioloop=kqueue
     have_ioloop=yes
-  ], [
-    ioloop=""
-  ])
+  fi
 fi
 
 if test "$ioloop" = "" || test "$ioloop" = "poll"; then
@@ -411,6 +416,19 @@
   ], [
     AC_MSG_ERROR([inotify requested but not available, check for existence of <linux/inotify.h> and <linux/inotify-syscalls.h>])
   ])
+elif test "$notify" = "kqueue"; then
+  dnl * BSD kqueue() notify
+  if test "$ac_cv_func_kqueue" != yes ; then
+    AC_MSG_WARN([kqueue notify requested but kqueue() is not available])
+    notify=""
+  elif test "$ac_cv_func_kevent" != yes ; then
+    AC_MSG_WARN([kqueue notify requested but kevent() is not available])
+    notify=""
+  else
+    have_notify=kqueue
+    AC_DEFINE(IOLOOP_NOTIFY_KQUEUE,,
+      Use BSD kqueue directory changes notificaton)
+  fi
 else
   AC_MSG_ERROR([Unknown notify method: $notify])
 fi
@@ -1542,6 +1560,7 @@
 
 CFLAGS="$CFLAGS $EXTRA_CFLAGS"
 
+AC_CONFIG_HEADERS([config.h])
 AC_CONFIG_FILES([
 Makefile
 doc/Makefile