diff configure.in @ 1995:cc64f8bb4716 HEAD

MySQL authentication patch by Matther Reimer
author Timo Sirainen <tss@iki.fi>
date Mon, 10 May 2004 04:47:08 +0300
parents 049502ef137e
children ec22548b6124
line wrap: on
line diff
--- a/configure.in	Mon May 10 04:28:19 2004 +0300
+++ b/configure.in	Mon May 10 04:47:08 2004 +0300
@@ -134,6 +134,15 @@
 	fi,
 	want_pgsql=no)
 
+AC_ARG_WITH(mysql,
+[  --with-mysql            Build with MySQL support],
+	if test x$withval = xno; then
+		want_mysql=no
+	else
+		want_mysql=yes
+	fi,
+	want_mysql=no)
+
 AC_ARG_WITH(cyrus-sasl2,
 [  --with-cyrus-sasl2      Build with Cyrus SASL 2 library support],
 	if test x$withval = xno; then
@@ -1016,6 +1025,25 @@
 	LIBS=$old_LIBS
 fi
 
+if test $want_mysql = yes; then
+	AC_CHECK_LIB(mysqlclient, mysql_init, [
+		AC_CHECK_HEADER(mysql.h,, [
+			AC_CHECK_HEADER(mysql/mysql.h, [
+				AUTH_CFLAGS="$AUTH_CFLAGS -DHAVE_MYSQL_MYSQL_H"
+			], want_mysql = no)
+		])
+	], want_mysql = no)
+
+	if test $want_mysql = yes; then
+		AUTH_LIBS="$AUTH_LIBS -lmysqlclient"
+
+        	AC_DEFINE(USERDB_MYSQL,, Build with MySQL support)
+		AC_DEFINE(PASSDB_MYSQL,, Build with MySQL support)
+		userdb="$userdb mysql"
+		passdb="$passdb mysql"
+	fi
+fi
+
 if test $want_vpopmail = yes; then
 	vpopmail_home="`echo ~vpopmail`"
 	vpop_libdeps="$vpopmail_home/etc/lib_deps"