diff configure.in @ 1851:d66d53f57e43 HEAD

Added bsdauth support, patch by Dan Cross
author Timo Sirainen <tss@iki.fi>
date Wed, 29 Oct 2003 16:10:20 +0200
parents 83c635deda0b
children a0de7b3f133c
line wrap: on
line diff
--- a/configure.in	Wed Oct 29 15:53:12 2003 +0200
+++ b/configure.in	Wed Oct 29 16:10:20 2003 +0200
@@ -89,6 +89,15 @@
 	fi,
 	want_pam=yes)
 
+AC_ARG_WITH(bsdauth,
+[  --with-bsdauth          Build with BSD authentication support (default)],
+	if test x$withval = xno; then
+		want_bsdauth=no
+	else
+		want_bsdauth=yes
+	fi,
+	want_bsdauth=yes)
+
 AC_ARG_WITH(ldap,
 [  --with-ldap             Build with LDAP support],
 	if test x$withval = xno; then
@@ -938,6 +947,13 @@
 	])
 fi
 
+if test $want_bsdauth = yes; then
+	AC_CHECK_FUNC(auth_userokay, [
+		AC_DEFINE(PASSDB_BSDAUTH,, Build with BSD authentication support)
+		passdb="$passdb bsdauth"
+	])
+fi
+
 if test $want_ldap = yes; then
 	AC_CHECK_LIB(ldap, ldap_init, [
 		AC_CHECK_HEADER(ldap.h, [