diff configure.ac @ 18239:d938a49c2045

dovecot.m4: External plugins can now more easily run their tests via Valgrind. DC_DOVECOT macro automatically adds RUN_TEST variable to Makefiles, which can be used to call any test programs. If valgrind exists, the tests are run through it. This is done by writing run-test.sh to the build directory, so the original run-test.sh in hg is no longer needed.
author Timo Sirainen <tss@iki.fi>
date Tue, 10 Feb 2015 13:12:42 +0200
parents 6078354e6238
children 3ac5933082c4
line wrap: on
line diff
--- a/configure.ac	Tue Feb 10 12:31:12 2015 +0200
+++ b/configure.ac	Tue Feb 10 13:12:42 2015 +0200
@@ -2816,13 +2816,7 @@
 fi
 AC_SUBST(docdir)
 
-AC_CHECK_PROG(VALGRIND, valgrind, yes, no)
-if test $VALGRIND = yes; then
-  RUN_TEST='$(SHELL) $(top_srcdir)/run-test.sh'
-else
-  RUN_TEST=''
-fi
-AC_SUBST(RUN_TEST)
+DC_DOVECOT_TEST_WRAPPER
 AC_SUBST(abs_top_builddir)
 
 AC_CONFIG_HEADERS([config.h])