diff src/plugins/expire/Makefile.am @ 11398:da750dc62c14 HEAD

expire: Rewrote expire-tool as a plugin for doveadm. Whenever using some doveadm mail command with -A parameter, the plugin checks if it can get the list of potentially matching users from the expire database. Currently only the list of users is filtered based on expire database, list of mailboxes could also be filtered but this isn't supported (yet).
author Timo Sirainen <tss@iki.fi>
date Thu, 27 May 2010 20:30:04 +0100
parents 2b4e61bfb645
children 0be58f3930b2
line wrap: on
line diff
--- a/src/plugins/expire/Makefile.am	Thu May 27 20:00:28 2010 +0100
+++ b/src/plugins/expire/Makefile.am	Thu May 27 20:30:04 2010 +0100
@@ -1,4 +1,4 @@
-pkglibexecdir = $(libexecdir)/dovecot
+doveadm_moduledir = $(moduledir)/doveadm
 
 AM_CPPFLAGS = \
 	-I$(top_srcdir)/src/lib \
@@ -10,35 +10,25 @@
 	-I$(top_srcdir)/src/lib-imap \
 	-I$(top_srcdir)/src/lib-index \
 	-I$(top_srcdir)/src/lib-storage \
-	-I$(top_srcdir)/src/lib-storage/index
+	-I$(top_srcdir)/src/lib-storage/index \
+	-I$(top_srcdir)/src/doveadm
 
+lib10_doveadm_expire_plugin_la_LDFLAGS = -module -avoid-version
 lib20_expire_plugin_la_LDFLAGS = -module -avoid-version
 
 module_LTLIBRARIES = \
 	lib20_expire_plugin.la
 
 lib20_expire_plugin_la_SOURCES = \
-	expire-env.c \
+	expire-set.c \
 	expire-plugin.c
 
 noinst_HEADERS = \
-	expire-env.h \
+	expire-set.h \
 	expire-plugin.h
 
-pkglibexec_PROGRAMS = expire-tool
-
-expire_tool_SOURCES = \
-	expire-tool.c
+doveadm_module_LTLIBRARIES = \
+	lib10_doveadm_expire_plugin.la
 
-if !BUILD_SHARED_LIBS
-unused_objects = \
-	$(top_builddir)/src/lib/mountpoint.o
-endif
-
-libs = \
-	expire-env.lo \
-	$(LIBDOVECOT_STORAGE) \
-	$(unused_objects)
-
-expire_tool_LDADD = $(libs) $(LIBDOVECOT) $(MODULE_LIBS)
-expire_tool_DEPENDENCIES = $(libs) $(LIBDOVECOT_DEPS)
+lib10_doveadm_expire_plugin_la_SOURCES = \
+	doveadm-expire.c