diff configure.in @ 13930:e0ff21d73630

configure: Add -fno-builtin-strftime flag with gcc to avoid warning.
author Timo Sirainen <tss@iki.fi>
date Wed, 11 Jan 2012 10:31:25 +0200
parents 5398bdb8613f
children a20a99b8815d
line wrap: on
line diff
--- a/configure.in	Tue Jan 10 23:34:43 2012 +0200
+++ b/configure.in	Wed Jan 11 10:31:25 2012 +0200
@@ -301,6 +301,9 @@
 	# -Wmissing-format-attribute -Wmissing-noreturn -Wwrite-strings # a couple of warnings
 	CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast"
 
+	# This is simply to avoid warning when building strftime() wrappers..
+	CFLAGS="$CFLAGS -fno-builtin-strftime"
+
 	AC_TRY_COMPILE([
 	#if __GNUC__ < 4
 	#  error old gcc