diff src/plugins/expire/Makefile.am @ 4910:e66dc3774099 HEAD

Changed the plugin filename numbering (ie. the ordering in which the plugins are loaded). This doesn't change anything for current plugins, but future plugins will need this change so they can get themselves loaded between specific plugins.
author Timo Sirainen <tss@iki.fi>
date Sat, 16 Dec 2006 01:46:22 +0200
parents 6ab2712f1a93
children 145f721b6412
line wrap: on
line diff
--- a/src/plugins/expire/Makefile.am	Sat Dec 16 01:08:42 2006 +0200
+++ b/src/plugins/expire/Makefile.am	Sat Dec 16 01:46:22 2006 +0200
@@ -9,12 +9,12 @@
 	-I$(top_srcdir)/src/lib-storage/index \
 	-DPKG_RUNDIR=\""$(rundir)"\"
 
-lib01_expire_plugin_la_LDFLAGS = -module -avoid-version
+lib20_expire_plugin_la_LDFLAGS = -module -avoid-version
 
 module_LTLIBRARIES = \
-	lib01_expire_plugin.la
+	lib20_expire_plugin.la
 
-lib01_expire_plugin_la_SOURCES = \
+lib20_expire_plugin_la_SOURCES = \
 	expire-env.c \
 	expire-plugin.c
 
@@ -52,6 +52,6 @@
 	  $(DESTDIR)$(moduledir)/pop3 \
 	  $(DESTDIR)$(moduledir)/lda
 	for d in imap pop3 lda; do \
-	  rm -f $(DESTDIR)$(moduledir)/$$d/lib01_expire_plugin.so; \
-	  $(LN_S) ../lib01_expire_plugin.so $(DESTDIR)$(moduledir)/$$d; \
+	  rm -f $(DESTDIR)$(moduledir)/$$d/lib20_expire_plugin.so; \
+	  $(LN_S) ../lib20_expire_plugin.so $(DESTDIR)$(moduledir)/$$d; \
 	done