diff Makefile.am @ 11117:eee1e2a1c25b HEAD

configure: Removed --enable-header-install. It's now always enabled. There didn't seem to be much point in keeping it optional anymore. They're now more useful than before because shared libraries are also installed.
author Timo Sirainen <tss@iki.fi>
date Thu, 08 Apr 2010 04:49:47 +0300
parents a2c6c91635b5
children b11f69e5078e
line wrap: on
line diff
--- a/Makefile.am	Thu Apr 08 04:48:55 2010 +0300
+++ b/Makefile.am	Thu Apr 08 04:49:47 2010 +0300
@@ -23,12 +23,8 @@
 datafiles = \
 	dovecot-config
 
-if INSTALL_HEADERS
-  nodist_pkginclude_HEADERS = config.h
-  pkglib_DATA = $(datafiles)
-else
-  noinst_DATA = $(datafiles)
-endif
+nodist_pkginclude_HEADERS = config.h
+pkglib_DATA = $(datafiles)
 
 if MAINTAINER_MODE
 ChangeLog: .hg/dirstate
@@ -56,7 +52,6 @@
 	-e "s|^\(dovecot_moduledir\)=|\1=$(moduledir)|" \
 	> dovecot-config
 
-if INSTALL_HEADERS
 install-exec-hook:
 	rm $(DESTDIR)$(pkglibdir)/dovecot-config && \
 	grep -v '^LIBDOVECOT_.*_INCLUDE' dovecot-config | \
@@ -67,9 +62,6 @@
 	-e "s|^\(LIBDOVECOT_STORAGE\)=.*$$|\1=-ldovecot-storage|" \
 	-e "s|^\(LIBDOVECOT_INCLUDE\)=.*$$|\1=-I$(pkgincludedir)|" \
 	> $(DESTDIR)$(pkglibdir)/dovecot-config
-else
-install-exec-hook:
-endif
 
 CLEANFILES = $(datafiles)