diff configure.in @ 11117:eee1e2a1c25b HEAD

configure: Removed --enable-header-install. It's now always enabled. There didn't seem to be much point in keeping it optional anymore. They're now more useful than before because shared libraries are also installed.
author Timo Sirainen <tss@iki.fi>
date Thu, 08 Apr 2010 04:49:47 +0300
parents 6891d20929ca
children 829cc91ed831
line wrap: on
line diff
--- a/configure.in	Thu Apr 08 04:48:55 2010 +0300
+++ b/configure.in	Thu Apr 08 04:49:47 2010 +0300
@@ -254,16 +254,6 @@
 	want_docs=yes)
 AM_CONDITIONAL(BUILD_DOCS, test "$want_docs" = "yes")
 
-AC_ARG_ENABLE(header-install,
-[  --enable-header-install Install development headers],
-	if test x$enableval = xno; then
-		want_headers=no
-	else
-		want_headers=yes
-	fi,
-	want_headers=no)
-AM_CONDITIONAL(INSTALL_HEADERS, test "$want_headers" = "yes")
-
 dnl always enable all of the passbs and userdbs that don't require extra libs
 want_passwd=yes
 want_passwd_file=yes
@@ -2016,7 +2006,9 @@
 				AC_DEFINE(LDAP_HAVE_START_TLS_S,, Define if you have ldap_start_tls_s)
 			])
 			LDAP_LIBS="-lldap"
-			AC_CHECK_LIB(ldap, ber_free,, [
+			AC_CHECK_LIB(ldap, ber_free, [
+			  # do nothing, default is to add -lldap to LIBS
+			], [
 			  AC_CHECK_LIB(lber, ber_free, [
 			    LDAP_LIBS="$LDAP_LIBS -llber"
 			  ])