diff configure.in @ 4552:ef71b2fdd433 HEAD

Put back specific checks for struct dqblk.dqb_curblocks vs curspace. The removal broke compiling for some OSes such as OSX.
author Timo Sirainen <tss@iki.fi>
date Thu, 10 Aug 2006 20:46:05 +0300
parents 2643a46322a6
children a54558861acc
line wrap: on
line diff
--- a/configure.in	Thu Aug 10 20:28:31 2006 +0300
+++ b/configure.in	Thu Aug 10 20:46:05 2006 +0300
@@ -1141,6 +1141,36 @@
   AC_MSG_RESULT(no)
 ])
 
+dnl * Check if we have struct dqblk.dqb_curblocks
+AC_MSG_CHECKING([if struct dqblk.dqb_curblocks exists])
+AC_TRY_COMPILE([
+  #include <sys/types.h>
+  #include "$srcdir/src/plugins/quota/quota-fs.h"
+], [
+  struct dqblk dqblk;
+  unsigned int x = dqblk.dqb_curblocks;
+], [
+  AC_DEFINE(HAVE_STRUCT_DQBLK_CURBLOCKS,, Define if struct sqblk.dqb_curblocks exists)
+  AC_MSG_RESULT(yes)
+], [
+  AC_MSG_RESULT(no)
+])
+
+dnl * Check if we have struct dqblk.dqb_curspace
+AC_MSG_CHECKING([if struct dqblk.dqb_curspace exists])
+AC_TRY_COMPILE([
+  #include <sys/types.h>
+  #include "$srcdir/src/plugins/quota/quota-fs.h"
+], [
+  struct dqblk dqblk;
+  unsigned int x = dqblk.dqb_curspace;
+], [
+  AC_DEFINE(HAVE_STRUCT_DQBLK_CURSPACE,, Define if struct sqblk.dqb_curspace exists)
+  AC_MSG_RESULT(yes)
+], [
+  AC_MSG_RESULT(no)
+])
+
 dnl * Check if we have Q_QUOTACTL ioctl (Solaris)
 AC_MSG_CHECKING([if struct Q_QUOTACTL ioctl exists])
 AC_TRY_COMPILE([