diff src/lib-oauth2/Makefile.am @ 21575:f6d27a985066

lib-oauth2: Add support library for OAUTH2
author Aki Tuomi <aki.tuomi@dovecot.fi>
date Thu, 26 Jan 2017 10:49:08 +0200
parents
children
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/src/lib-oauth2/Makefile.am	Thu Jan 26 10:49:08 2017 +0200
@@ -0,0 +1,23 @@
+AM_CPPFLAGS = \
+	-I$(top_srcdir)/src/lib \
+	-I$(top_srcdir)/src/lib-http \
+	-I$(top_srcdir)/src/lib-settings
+
+noinst_LTLIBRARIES=liboauth2.la
+
+pkginc_libdir=$(pkgincludedir)
+pkginc_lib_HEADERS = \
+	oauth2.h
+
+noinst_HEADERS = \
+	oauth2-private.h
+
+liboauth2_la_SOURCES = \
+	oauth2.c \
+	oauth2-token-validate.c \
+	oauth2-introspect.c \
+	oauth2-refresh.c
+
+check_programs = \
+	oauth2-server \
+	test-oauth2