diff configure.in @ 2070:0c8f884d1648 HEAD

Added --with-moduledir configure option
author Timo Sirainen <tss@iki.fi>
date Wed, 26 May 2004 18:26:05 +0300
parents b3a56463c812
children b3daf55df932
line wrap: on
line diff
--- a/configure.in	Wed May 26 17:46:35 2004 +0300
+++ b/configure.in	Wed May 26 18:26:05 2004 +0300
@@ -1,7 +1,7 @@
 AC_INIT(src)
 
 AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(dovecot, 1.0-test10)
+AM_INIT_AUTOMAKE(dovecot, 1.0-test13)
 
 AM_MAINTAINER_MODE
 
@@ -206,6 +206,13 @@
 	mail_storages=`echo "$withval"|sed 's/,/ /g'` ],
 	mail_storages="maildir mbox")
 
+AC_ARG_WITH(moduledir,
+[  --with-moduledir=DIR    Base directory for dynamically loadable modules],
+	moduledir="$withval",
+	moduledir=$libdir/dovecot
+)
+AC_SUBST(moduledir)
+
 dnl * gcc specific options
 if test "x$ac_cv_prog_gcc" = "xyes"; then
 	# -Wcast-qual -Wcast-align -Wconversion # too many warnings