diff configure.in @ 4423:26d18749f718 HEAD

Fixes to io notify detection. Patch by Marcus Rueckert
author Timo Sirainen <tss@iki.fi>
date Sun, 18 Jun 2006 04:34:42 +0300
parents c46c02c7e602
children b8089cf41c96
line wrap: on
line diff
--- a/configure.in	Sun Jun 18 03:24:54 2006 +0300
+++ b/configure.in	Sun Jun 18 04:34:42 2006 +0300
@@ -422,6 +422,7 @@
 have_notify=none
 
 if test "$notify" = "" || test "$notify" = "inotify" ; then
+  AC_MSG_CHECKING([if we can use inotify])
   dnl * inotify?
   AC_TRY_RUN([
     #define _GNU_SOURCE
@@ -458,28 +459,36 @@
     have_notify=inotify
     notify=inotify
     AC_DEFINE(IOLOOP_NOTIFY_INOTIFY,, Use Linux inotify)
+    AC_MSG_RESULT("yes")
   ], [
+    AC_MSG_RESULT("no")
     if test "$notify" = "inotify"; then
       AC_MSG_WARN([inotify requested but not available])
+      notify=""
     fi
   ])
 fi
 
 if test "$notify" = "" || test "$notify" = "kqueue"; then
+  AC_MSG_CHECKING([if we can use BSD kqueue() notify])
   dnl * BSD kqueue() notify
   if test "$ac_cv_func_kqueue" == yes && test "$ac_cv_func_kevent" == yes ; then
     have_notify=kqueue
     notify=kqueue
+    AC_MSG_RESULT("yes")
     AC_DEFINE(IOLOOP_NOTIFY_KQUEUE,,
       Use BSD kqueue directory changes notificaton)
   else 
+    AC_MSG_RESULT("no")
     if test "$notfify" = "kqueue" ; then
       AC_MSG_WARN([kqueue notify requested but kqueue() is not available])
+      notify=""
     fi
   fi
 fi
 
 if test "$notify" = "" || test "$notify" = "dnotify"; then
+  AC_MSG_CHECKING([if we can use dnotify])
   dnl * dnotify?
   AC_TRY_COMPILE([
     #define _GNU_SOURCE
@@ -490,10 +499,12 @@
     fcntl(0, F_SETSIG, SIGRTMIN);
     fcntl(0, F_NOTIFY, DN_CREATE | DN_DELETE | DN_RENAME | DN_MULTISHOT);
   ], [
+    AC_MSG_RESULT("yes")
     AC_DEFINE(IOLOOP_NOTIFY_DNOTIFY,, Use Linux dnotify)
     have_notify=dnotify
     notify=dnotify
   ], [
+    AC_MSG_RESULT("no")
     if test "$notify" = "dnotify"; then
       AC_MSG_WARN([dnotify requested but not available])
     fi