diff configure.in @ 4022:2f26567685ff HEAD

Removed -Wstrict-aliasing=2 since it gives errors with older gccs
author Timo Sirainen <tss@iki.fi>
date Thu, 16 Feb 2006 16:58:31 +0200
parents 989dd95aa8b9
children 2fa6dc0e0e27
line wrap: on
line diff
--- a/configure.in	Wed Feb 15 21:37:34 2006 +0200
+++ b/configure.in	Thu Feb 16 16:58:31 2006 +0200
@@ -311,7 +311,8 @@
 	# -Wcast-qual -Wcast-align -Wconversion # too many warnings
 	# -Wstrict-prototypes -Wredundant-decls # may give warnings in some systems
 	# -Wmissing-format-attribute -Wmissing-noreturn -Wwrite-strings # a couple of warnings
-	CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast -Wstrict-aliasing=2"
+	# -Wstrict-aliasing=2 # requires new gcc
+	CFLAGS="$CFLAGS -Wall -W -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wchar-subscripts -Wformat=2 -Wbad-function-cast"
 
 	# Use std=gnu99 if we have new enough gcc
 	old_cflags=$CFLAGS