diff configure.in @ 4567:32f5df3de2d1 HEAD

eval doesn't need to have its parameters quoted. The previous \" quoting was broken with POSIX shells (and autoconf 2.60 now sets POSIX mode to non-bash/zsh shells also where this was previously working wrong). So, all in all this should fix OpenBSD compiling problems.
author Timo Sirainen <tss@iki.fi>
date Fri, 11 Aug 2006 02:21:06 +0300
parents a54558861acc
children 79dd8a12fa05
line wrap: on
line diff
--- a/configure.in	Fri Aug 11 01:32:10 2006 +0300
+++ b/configure.in	Fri Aug 11 02:21:06 2006 +0300
@@ -651,7 +651,7 @@
 
       for type in $order; do
         actype="ac_cv_sizeof_`echo $type|sed 's/-/_/g'`"
-        if test "$size" = "`eval \"echo \\$$actype\"`"; then
+        if test "$size" = "`eval echo \\$$actype`"; then
 	  result="`echo $type|sed 's/-/ /g'`"
 	  visible="`expr $size \* 8`bit (using $result)"
 	  break
@@ -1720,7 +1720,7 @@
   if test "$storage" = "$deliver_storage"; then
     deliver_storage=""
   fi
-  STORAGE_LIBS="$STORAGE_LIBS `eval \"echo \\$${storage}_libs\"`"
+  STORAGE_LIBS="$STORAGE_LIBS `eval echo \\$${storage}_libs`"
 done
 STORAGE_LIBS="$STORAGE_LIBS $index_libs"
 AC_SUBST(STORAGE_LIBS)