diff configure.in @ 1660:4076387f7ccb HEAD

We should be checking C99 types using stdint.h, not inttypes.h
author Timo Sirainen <tss@iki.fi>
date Tue, 05 Aug 2003 22:45:02 +0300
parents 20519e4bca48
children a0dd52443420
line wrap: on
line diff
--- a/configure.in	Sun Aug 03 21:54:56 2003 +0300
+++ b/configure.in	Tue Aug 05 22:45:02 2003 +0300
@@ -478,13 +478,19 @@
   AC_MSG_RESULT($i_cv_type_$1)
 ])
 
-AC_CHECKTYPE2(uintmax_t, [#include <inttypes.h>])
+dnl some systems don't have stdint.h, but still have some of the types
+dnl defined elsewhere
+AC_CHECK_HEADER(stdint.h, [
+  stdint_include="#include <stdint.h>"
+])
+
+AC_CHECKTYPE2(uintmax_t, [$stdint_include])
 if test $i_cv_type_uintmax_t = yes; then
   AC_DEFINE(HAVE_UINTMAX_T,, Define if you have uintmax_t (C99 type))
 fi
 
 dnl use separate check, eg. Solaris 8 has uintmax_t but not uint_fast32_t
-AC_CHECKTYPE2(uint_fast32_t, [#include <inttypes.h>])
+AC_CHECKTYPE2(uint_fast32_t, [$stdint_include])
 if test $i_cv_type_uint_fast32_t = yes; then
   AC_DEFINE(HAVE_UINT_FAST32_T,, Define if you have uint_fast32_t (C99 type))
 fi