diff configure.in @ 544:42e65c2ba49d HEAD

Added --enable-debug. Currently it just forces file locks so that index files can't be written to when not holding exclusive lock. Also main index file can't be even read if we're unlocked (other files don't get notification of unlock, so they don't do this at least yet).
author Timo Sirainen <tss@iki.fi>
date Mon, 28 Oct 2002 11:31:40 +0200
parents e815df17e52e
children e1254b838e0b
line wrap: on
line diff
--- a/configure.in	Mon Oct 28 11:00:25 2002 +0200
+++ b/configure.in	Mon Oct 28 11:31:40 2002 +0200
@@ -28,6 +28,12 @@
 	fi,
 	want_ipv6=yes)
 
+AC_ARG_ENABLE(debug,
+[  --enable-debug          Enable some extra checks for debugging],
+	if test x$enableval = xyes; then
+		AC_DEFINE(DEBUG)
+	fi)
+
 AC_ARG_WITH(file-offset-size,
 [  --with-file-offset-size=BITS  Set size of file offsets. Usually 32 or 64.
                           (default: 64 if available)],