diff src/auth/Makefile.am @ 2798:54b29901a793 HEAD

Added simple LRU cache for auth requests. Currently only for sql passdb.
author Timo Sirainen <tss@iki.fi>
date Thu, 21 Oct 2004 05:23:09 +0300
parents fb7f862194b5
children 5e2e4cdbfe2e
line wrap: on
line diff
--- a/src/auth/Makefile.am	Thu Oct 21 02:34:34 2004 +0300
+++ b/src/auth/Makefile.am	Thu Oct 21 05:23:09 2004 +0300
@@ -32,6 +32,7 @@
 	$(MODULE_LIBS)
 
 dovecot_auth_SOURCES = \
+	auth-cache.c \
 	auth-client-connection.c \
 	auth-master-connection.c \
 	auth-module.c \
@@ -50,6 +51,7 @@
 	mech-apop.c \
 	passdb.c \
 	passdb-bsdauth.c \
+	passdb-cache.c \
 	passdb-ldap.c \
 	passdb-passwd.c \
 	passdb-passwd-file.c \
@@ -67,6 +69,7 @@
 	userdb-sql.c
 
 noinst_HEADERS = \
+	auth-cache.h \
 	auth-client-connection.h \
 	auth-client-interface.h \
 	auth-master-interface.h \
@@ -79,6 +82,7 @@
 	mech.h \
 	mycrypt.h \
 	passdb.h \
+	passdb-cache.h \
 	password-scheme.h \
 	userdb.h \
 	userdb-vpopmail.h