diff configure.in @ 1729:5bf22d6bb65e HEAD

Added IO_DIR_NOTIFY and IO_FILE_NOTIFY conditions to io_add(). IO_DIR_NOTIFY is now implemented for Linux dnotify.
author Timo Sirainen <tss@iki.fi>
date Sun, 24 Aug 2003 15:43:53 +0300
parents a0dee56b280d
children 49b6103dd2e0
line wrap: on
line diff
--- a/configure.in	Sun Aug 24 13:49:14 2003 +0300
+++ b/configure.in	Sun Aug 24 15:43:53 2003 +0300
@@ -225,6 +225,21 @@
 	AC_DEFINE(IOLOOP_SELECT,, Implement I/O loop with select())
 ])
 
+dnl * dnotify?
+AC_TRY_COMPILE([
+  #define _GNU_SOURCE
+  #include <fcntl.h>
+  #include <signal.h>
+  #include <unistd.h>
+], [
+  fcntl(0, F_SETSIG, SIGRTMIN);
+  fcntl(0, F_NOTIFY, DN_CREATE | DN_DELETE | DN_RENAME | DN_MULTISHOT);
+], [
+  AC_DEFINE(IOLOOP_NOTIFY_DNOTIFY,, Use Linux dnotify)
+], [
+  AC_DEFINE(IOLOOP_NOTIFY_NONE,, No special notify support)
+])
+
 dnl * OS specific options
 case "$host_os" in
 	hpux*)