diff configure.in @ 3062:5e2e4cdbfe2e HEAD

Added "passdb" userdb. It works only if passdb gives all the information needed for userdb. For example with SQL you can use ".. uid AS userdb_uid, gid AS userdb_gid, home AS userdb_home .." in password_query.
author Timo Sirainen <tss@iki.fi>
date Fri, 07 Jan 2005 20:15:14 +0200
parents 60a172e62d11
children 0704b595c873
line wrap: on
line diff
--- a/configure.in	Fri Jan 07 20:09:40 2005 +0200
+++ b/configure.in	Fri Jan 07 20:15:14 2005 +0200
@@ -138,6 +138,15 @@
 	fi,
 	want_static_userdb=yes)
 
+AC_ARG_WITH(passdb-userdb,
+[  --with-passdb-userdb    Build with passdb userdb support (default)],
+	if test x$withval = xno; then
+		want_passdb_userdb=no
+	else
+		want_passdb_userdb=yes
+	fi,
+	want_passdb_userdb=yes)
+
 AC_ARG_WITH(pgsql,
 [  --with-pgsql            Build with PostgreSQL support],
 	if test x$withval = xno; then
@@ -999,6 +1008,11 @@
 	userdb="$userdb static"
 fi
 
+if test $want_passdb_userdb = yes; then
+        AC_DEFINE(USERDB_PASSDB,, Build with passdb userdb support)
+	userdb="$userdb passdb"
+fi
+
 if test $want_passwd = yes; then
 	need_crypt=yes
         AC_DEFINE(USERDB_PASSWD,, Build with passwd support)