diff src/auth/Makefile.am @ 8872:643a96aec996 HEAD

Fixed --with-ldap=plugin and --with-gssapi=plugin
author Timo Sirainen <tss@iki.fi>
date Thu, 26 Mar 2009 18:36:36 -0400
parents 33eae1ca0be0
children e3fe9b4a6a2d
line wrap: on
line diff
--- a/src/auth/Makefile.am	Thu Mar 26 18:17:09 2009 -0400
+++ b/src/auth/Makefile.am	Thu Mar 26 18:36:36 2009 -0400
@@ -48,14 +48,6 @@
 
 ldap_sources = db-ldap.c passdb-ldap.c userdb-ldap.c
 
-if ! LDAP_PLUGIN
-builtin_ldap_sources = $(ldap_sources)
-endif
-
-if ! GSSAPI_PLUGIN
-builtin_gssapi_sources = mech-gssapi.c
-endif
-
 dovecot_auth_SOURCES = \
 	auth.c \
 	auth-cache.c \
@@ -77,6 +69,7 @@
 	mech-login.c \
 	mech-cram-md5.c \
 	mech-digest-md5.c \
+	mech-gssapi.c \
 	mech-ntlm.c \
 	mech-otp.c \
 	mech-skey.c \
@@ -107,8 +100,7 @@
 	userdb-static.c \
 	userdb-vpopmail.c \
 	userdb-sql.c \
-	$(builtin_gssapi_sources) \
-	$(builtin_ldap_sources)
+	$(ldap_sources)
 
 headers = \
 	auth.h \
@@ -144,14 +136,14 @@
 if GSSAPI_PLUGIN
 libmech_gssapi_la_LDFLAGS = -module -avoid-version
 libmech_gssapi_la_LIBADD = $(KRB5_LIBS)
-libmech_gssapi_la_CPPFLAGS = $(AM_CPPFLAGS) $(KRB5_CFLAGS)
+libmech_gssapi_la_CPPFLAGS = $(AM_CPPFLAGS) $(KRB5_CFLAGS) -DPLUGIN_BUILD
 libmech_gssapi_la_SOURCES = mech-gssapi.c
 endif
 
 if LDAP_PLUGIN
 libauthdb_ldap_la_LDFLAGS = -module -avoid-version
 libauthdb_ldap_la_LIBADD = $(LDAP_LIBS)
-libauthdb_ldap_la_CPPFLAGS = $(AM_CPPFLAGS)
+libauthdb_ldap_la_CPPFLAGS = $(AM_CPPFLAGS) -DPLUGIN_BUILD
 libauthdb_ldap_la_SOURCES = $(ldap_sources)
 endif