diff configure.in @ 7844:7b39370dae6b HEAD

If we need -lcrypto for randomness, put it to $LIBS instead of $RAND_LIBS since it needs to be linked to all binaries anyway.
author Timo Sirainen <tss@iki.fi>
date Thu, 12 Jun 2008 23:11:45 +0300
parents b63aa0ffe564
children 35877d1131db
line wrap: on
line diff
--- a/configure.in	Tue Jun 17 04:52:57 2008 +0300
+++ b/configure.in	Thu Jun 12 23:11:45 2008 +0300
@@ -909,10 +909,9 @@
 
   AC_CHECK_HEADER(openssl/rand.h, [
     AC_DEFINE(HAVE_OPENSSL_RAND_H,, Define if you have openssl/rand.h)
-    RAND_LIBS=-lcrypto
+    LIBS="$LIBS -lcrypto"
   ])
 fi
-AC_SUBST(RAND_LIBS)
 
 dnl * do we have tm_gmtoff
 AC_MSG_CHECKING([for tm_gmtoff])