diff src/plugins/quota/Makefile.am @ 6177:abec53314897 HEAD

Build rquota_xdr.c with rpcgen from rquota.x.
author Timo Sirainen <tss@iki.fi>
date Mon, 06 Aug 2007 19:07:36 +0300
parents 078d9dde99c8
children 0dda1f746d63
line wrap: on
line diff
--- a/src/plugins/quota/Makefile.am	Mon Aug 06 18:25:30 2007 +0300
+++ b/src/plugins/quota/Makefile.am	Mon Aug 06 19:07:36 2007 +0300
@@ -27,6 +27,13 @@
         quota-plugin.c \
 	quota-storage.c
 
+if HAVE_RQUOTA
+rquota_xdr.c: Makefile
+	$(RPCGEN) -c /usr/include/rpcsvc/rquota.x | \
+	  $(SED) -e 's/IXDR_PUT/(void)IXDR_PUT/g' \
+	    -e 's/int32_t \*buf/int32_t *buf __attr_unused__/' > rquota_xdr.c
+endif
+
 noinst_HEADERS = \
 	quota.h \
 	quota-fs.h \
@@ -39,3 +46,8 @@
 	  rm -f $(DESTDIR)$(moduledir)/$$d/lib10_quota_plugin.so; \
 	  $(LN_S) ../lib10_quota_plugin.so $(DESTDIR)$(moduledir)/$$d; \
 	done
+
+DISTFILES = $(DIST_COMMON) $(dist_sources) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
+
+distclean-generic:
+	rm -f Makefile rquota_xdr.c