diff configure.in @ 439:b66ccecbc8a6 HEAD

Added --with-mem-align=BYTES option
author Timo Sirainen <tss@iki.fi>
date Wed, 16 Oct 2002 04:25:14 +0300
parents 951cb252e577
children c634b705f24b
line wrap: on
line diff
--- a/configure.in	Wed Oct 16 04:12:50 2002 +0300
+++ b/configure.in	Wed Oct 16 04:25:14 2002 +0300
@@ -30,10 +30,15 @@
 
 AC_ARG_WITH(file-offset-size,
 [  --with-file-offset-size=BITS  Set size of file offsets. Usually 32 or 64.
-                          (default: 64 if available) ],
+                          (default: 64 if available)],
 	preferred_off_t_bits=$withval,
 	preferred_off_t_bits=64)
 
+AC_ARG_WITH(mem-align,
+[  --with-mem-align=BYTES  Set the memory alignment (default: 8)],
+	mem_align=$withval,
+	mem_align=8)
+
 AC_ARG_WITH(passwd,
 [  --with-passwd           Build with /etc/passwd support (default)],
 	if test x$withval = xno; then
@@ -216,11 +221,8 @@
   AC_DEFINE(LARGEST_T_LONG)
 fi
 
-dnl * memory alignment, needed with non-x86 systems and should speed up
-dnl * x86 systems too. Use 8 with everyone to make sure 64bit lookups
-dnl * work. Currently it should also be safe to set to 4 if off_t == 32bit.
-dnl * With x86 it could be 1 as well if you want to save a bit space/memory.
-AC_DEFINE(MEM_ALIGN_SIZE, 8)
+dnl * memory alignment
+AC_DEFINE_UNQUOTED(MEM_ALIGN_SIZE, $mem_align)
 
 dnl * socklen_t - AC_CHECK_TYPE() would be _really_ useful if it only would
 dnl * accept header files where to find the typedef..