diff configure.in @ 6501:dee85392c5c1 HEAD

Make sure we don't define BUILTIN_GSSAPI unless HAVE_GSSAPI is also defined.
author Timo Sirainen <tss@iki.fi>
date Tue, 25 Sep 2007 19:34:02 +0300
parents 1d45cf642d86
children 6c46542a5ce5
line wrap: on
line diff
--- a/configure.in	Tue Sep 25 18:01:20 2007 +0300
+++ b/configure.in	Tue Sep 25 19:34:02 2007 +0300
@@ -1603,16 +1603,16 @@
 					AC_DEFINE(HAVE___GSS_USEROK,,
 						Define if you have __gss_userok())
 				],, $KRB5_LIBS)
+
+				if test x$want_gssapi_plugin != xyes; then
+				  AUTH_LIBS="$AUTH_LIBS $KRB5_LIBS"
+				  AUTH_CFLAGS="$AUTH_CFLAGS `krb5-config --cflags gssapi`"
+				  AC_DEFINE(BUILTIN_GSSAPI,, GSSAPI support is built in)
+				else
+				  have_gssapi_plugin=yes
+				fi
 			fi
 			CFLAGS=$old_CFLAGS
-
-			if test x$want_gssapi_plugin != xyes; then
-			  AUTH_LIBS="$AUTH_LIBS $KRB5_LIBS"
-			  AUTH_CFLAGS="$AUTH_CFLAGS `krb5-config --cflags gssapi`"
-		          AC_DEFINE(BUILTIN_GSSAPI,, GSSAPI support is built in)
-			else
-			  have_gssapi_plugin=yes
-			fi
 		fi
 	fi
 fi