diff configure.in @ 546:e1254b838e0b HEAD

Added --enable-asserts (default) and fixed some warnings when building without. Added i_unreached() to indicate supposedly unreachable code block and changed a existing i_assert(0) calls to it. Removed return_if_fail() and return_val_if_fail() macros, they're not useful.
author Timo Sirainen <tss@iki.fi>
date Mon, 28 Oct 2002 11:46:02 +0200
parents 42e65c2ba49d
children 39a24074abf4
line wrap: on
line diff
--- a/configure.in	Mon Oct 28 11:40:15 2002 +0200
+++ b/configure.in	Mon Oct 28 11:46:02 2002 +0200
@@ -34,6 +34,12 @@
 		AC_DEFINE(DEBUG)
 	fi)
 
+AC_ARG_ENABLE(asserts,
+[  --enable-asserts        Enable asserts (default)],
+	if test x$enableval = xno; then
+		AC_DEFINE(DISABLE_ASSERTS)
+	fi)
+
 AC_ARG_WITH(file-offset-size,
 [  --with-file-offset-size=BITS  Set size of file offsets. Usually 32 or 64.
                           (default: 64 if available)],